В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Составить программу вычисления функции на паскале АВС.NET на заданных промежутках и с заданным шагом h.


x∈[0,π]
h=π/8

Используя var, const, writeln и т.д.


f= \frac{sinx+cosx}{1+x^2}
Составить программу вычисления функции на паскале АВС.NET на заданных промежутках и с заданным шаго

Показать ответ
Ответ:
CoJlne4Hblu
CoJlne4Hblu
06.08.2020 20:24
begin var f: real -> real := x -> (sin(x)+cos(x))/(1+sqr(x)); PartitionPoints(0, Pi, 8).Tabulate(x -> f(x)) .ForEach(x->writeln('x:',x.Item1:7:3,'    y:',x.Item2:7:3)); end.

или без косметики:

begin PartitionPoints(0,Pi,8).Tabulate(x->(sin(x)+cos(x))/(1+sqr(x))).Print end.

Примеры работ:


Составить программу вычисления функции на паскале АВС.NET на заданных промежутках и с заданным шагом
Составить программу вычисления функции на паскале АВС.NET на заданных промежутках и с заданным шагом
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота