В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Diana2004250
Diana2004250
21.04.2021 18:02 •  Информатика

Составить программу вычисления функций y=f(x) для заданного значения аргумента х, где f(x)=tg 2/3 x^2-ln|3x-5|+8.3.

Показать ответ
Ответ:
D202
D202
22.05.2023 00:21
// PascalABC.NET 3.0, сборка 1156 от 30.01.2016
function Avg(a:array[,] of integer):real;
begin
  var s:=0; var k:=0;
  foreach var e:integer in a do
    if e>0 then begin s+=e; Inc(k) end;
  if k>0 then Result:=s/k else Result:=1e-100;
end;

begin
  var A:=MatrixRandom(4,4,-50,50); Writeln(A);
  Writeln('Среднее арифметическое положительных равно ',Avg(A):0:3);
  var B:=MatrixRandom(5,5,-30,30); Writeln(B);
  Writeln('Среднее арифметическое положительных равно ',Avg(B):0:3);
  var C:=MatrixRandom(4,5,-25,38); Writeln(C);
  Writeln('Среднее арифметическое положительных равно ',Avg(C):0:3);
end.

Тестовое решение:
[[35,35,5,-47],[14,34,35,-13],[25,-5,35,-29],[-7,10,-12,12]]
Среднее арифметическое положительных равно 24.000
[[-12,-17,-10,19,14],[20,17,-27,-2,16],[-3,-21,30,2,10],[5,-3,-17,-3,18],[0,-26,29,1,-22]]
Среднее арифметическое положительных равно 15.083
[[-5,-11,17,-4,15],[15,17,-24,36,15],[-8,-3,-22,28,-25],[-21,6,12,31,-1]]
Среднее арифметическое положительных равно 19.200
0,0(0 оценок)
Ответ:
sofia308
sofia308
30.06.2022 19:10

Процесор вставляється в спеціальне місце – сокет (англ. socket – гніздо, розетка) на системній (материнській) платі, яка, у свою чергу, розміщується в системному блоці.

Для охолодження процесорів застосовують кулери — пристрої, які складаються з вентилятора і радіатора. На процесор встановлюють радіатор (зазвичай з алюмінію чи міді), а на нього — вентилятор, що забезпечує притік повітря до радіатора.

МАТЕРИНСЬКА ПЛАТА

Материнська, або системна, плата (від англ. motherboard) — це складна багатошарова друкована плата, до якої підключено практично всі пристрої комп’ютера. Друкована плата являє собою пластину з діелектрика, вкриту мережею мідних провідників-доріжок, якими електричні сигнали надходять до змонтованих на платі мікросхем та рознімів, куди вставляють інші пристрої комп’ютера.

На материнській платі розміщено центральний процесор та чіпсет (від англ. chip set) — набір мікросхем, спроектований для спільної роботи а метою виконання певних функцій. Оперативну пам’ять, відеокарту тощо вставляють у спеціальні розніми на материнській платі — слоти розширення.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота