В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
sonatap01f6p
sonatap01f6p
19.02.2023 20:09 •  Информатика

Составить программу вычисления и печати в виде таблицы значений функции и соответствующих аргументов, отладить программу на компьютере и получить распечатку программы и решения. На Pascal ABC.


Составить программу вычисления и печати в виде таблицы значений функции и соответствующих аргументов

Показать ответ
Ответ:
deniskakuzovle
deniskakuzovle
20.05.2021 16:12
// PascalABC.NET 3.3, сборка 1549 от 17.10.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Количество строк/столбцов в матрице:');
  Writeln('*** Исходная матрица ***');
  var a:array[,] of integer;
  repeat // обеспечить уникальность элементов
    a:=MatrRandom(n,n,-999,999)
  until a.Rows.SelectMany(x->x).Distinct.Count=n*n;
  a.Println(5); Writeln(5*a.ColCount*'-');
  var jmin:=a.ElementsWithIndexes.MinBy(t->t[0])[2];
  Writeln(a.Col(jmin).Sum)
end.

Пример
Количество строк/столбцов в матрице: 7
*** Исходная матрица ***
  666  963  808  847 -383 -453  695
 -233 -460 -311  606 -487 -243  -29
  479  438 -985  184  499   92  556
  -54  819   38 -962  790 -411 -155
 -320  525  340  390   76 -617 -747
 -439  585  332 -654  495  602  372
  551  229  906  837  480 -211 -438

1128
0,0(0 оценок)
Ответ:
BeautifulGirl001
BeautifulGirl001
05.04.2022 10:27
EDSAC (англ. Electronic Delay Storage Automatic Calculator) — электронная вычислительная машина, созданная в 1949 году в Кембриджском университете (Великобритания) группой разработчиков во главе с Морисом Уилксом.
МЭСМ (Малая электронная счётная машина) — первая в СССР и континентальной Европе электронно-вычислительная машина.Разрабатывалась лабораторией С. А. Лебедева
БЭСМ (сокращение от Большая (или Быстродействующая) электронно-счётная машина) — серия советских электронных вычислительных машин общего назначения, предназначенных для решения широкого круга задач. Разработка Института точной механики и вычислительной техники АН СССР
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота