В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
dashok270307
dashok270307
07.08.2021 02:02 •  Информатика

Составить программу вычисления количества натуральных нечётных чисел сумма квадратов которых не превысит 1000.( на паскале)

Показать ответ
Ответ:
werasdfghjfdfd
werasdfghjfdfd
15.09.2020 21:24
//PascalABC.NET (версия 3.1, сборка 1198 от 11.03.2016)
var
  a, s, n: integer;
begin
  while s < 1000 do
  begin
    if a mod 2 <> 0 then begin
      s := s + sqr(a);
      n := n + 1;
    end;
    a := a + 1;
  end;
  writeln(n-1);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота