В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
елена1154
елена1154
31.05.2023 10:51 •  Информатика

Составить программу вычисления объема цилиндра и конуса, которые имеют одинаковую высоту h и одинаковый радиус основания r (написать в паскале)

Показать ответ
Ответ:
ама34
ама34
02.10.2020 12:24
Пусть V1 - объем цилиндра, а V2 - объем конуса, тогда:
\displaystyle V_1= \pi R^2h \\ V_2= \frac{1}{3} \pi R^2h= \frac{1}{3}V_1

const
  pi=3.14;
var
  V1,V2,R,h:real;
begin
  Write('Введите радиус и высоту: '); Read(R,h);
  V1:=pi*sqr(R)*h; V2:=V1/3;
  Writeln('Объем цилиндра ',V1:0:5,', объем конуса ',V2:0:5)
end.

Тестовое решение:
Введите радиус и высоту: 5.5 12.81
Объем цилиндра 1216.75785, объем конуса 405.58595
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота