Составить программу вычисления стоимости покупки, если известна стоимость 1 кг конфет, печенья и яблок и количество купленных конфет, печенья и яблок. Ниже представлен рекомендуемый вид экрана во время работы программы: Введите исходные данные: Цена 1 кг конфет (руб.): 105 Количество кг конфет: 0.3 Цена 1 кг печенья (руб.): 73.5 Количество кг печенья: 1.2 Цена 1 кг яблок (руб.): 54.5 Количество кг яблок: 1.8 Стоимость покупки: 217.8 руб.
а - b(c+7).
n=15;
var
a:array[1..n] of integer;
i,j,k,t:integer;
begin
Randomize;
Writeln('Исходный массив');
k:=1;
for i:=1 to n do
begin
a[i]:=Random(99)+1;
Write(a[i],' ');
if a[i]>a[k] then k:=i
end;
Writeln;
for i:=1 to k-2 do
for j:=1 to k-2 do
if a[j] > a[j+1] then
begin t := a[j]; a[j] := a[j+1]; a[j+1] := t end;
for i:=k+1 to n-1 do
for j:=k+1 to n-1 do
if a[j] < a[j+1] then
begin t := a[j]; a[j] := a[j+1]; a[j+1] := t end;
Writeln('Упорядоченный массив');
for i:=1 to n do Write(a[i],' ');
end.