В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Lolilolokigh
Lolilolokigh
06.05.2021 07:02 •  Информатика

Составить программу вычисления стоимости покупки с учётом скидки. скидка 3% предоставляется в том случае, если сумма покупки больше 500 рублей, 5% - если сумма больше 1000 рублей. в результате вывести итоговую стоимость покупки и размер предоставленной скидки.

Показать ответ
Ответ:
margarita030620
margarita030620
03.10.2020 14:11
Var s:integer;
begin
write('Стоимость покупки = '); readln(s);
if s>1000
  then writeln('Скидка 5% (',s*0.05,' руб.), необходимо заплатить ',s*0.95)
  else if s>500
              then writeln('Скидка 3% (',s*0.03,' руб.), необходимо заплатить ',s*0.97)
              else writeln('Скидки нет');
end.

Пример:
Стоимость покупки = 600
Скидка 3% (18 руб.), необходимо заплатить 582
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота