В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
hhwjsbjweujskzks
hhwjsbjweujskzks
26.01.2022 12:33 •  Информатика

Составить программу вычисления суммы чисел, делящихся на 4 от 1 до N. Используйте цикл while.

Показать ответ
Ответ:
nastasttv00
nastasttv00
14.10.2020 21:53

Напишу сначала на простом языке по пунктам, потом на питоне:

считать N

x = 0 (счётчик)

s = 0 (сумматор)

пока x не равен N делать

x = x + 1

если x делится на 4, то s = s + x

цикл закончился

выводим s

Python:

n = int(input())

x = 0

s = 0

while x != n:

  x += 1

  if x % 4 == 0:

        s += x

print(s)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота