В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
din46
din46
10.04.2021 04:07 •  Информатика

Составить программу вычисления суммы элементов массива а, значения которых меньше чем -0,5. проверить работу программы за заданном массиве а(11). паскаль

Показать ответ
Ответ:
mprodeus99p0812l
mprodeus99p0812l
08.10.2020 14:05
Var
a: array[1..100] of real;
i,n:Integer;
sum: real;
begin
WriteLn('Введите количество элементов массива');
Readln(n);
WriteLn('Массив');
for i:=1 to n do
begin
a[i]:=(random(100)-50)/10;
Write(a[i]:5);
if a[i]< -0.5 then sum:=sum +a[i];
end;
Writeln;
Writeln('Сумма элементов меньших -0,5 = ', sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота