В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
nasamar
nasamar
03.02.2022 05:18 •  Информатика

Составить программу выводящую на экран все делители на число х.(число х вводится с клавиатуры)

Показать ответ
Ответ:
MarySolov
MarySolov
23.05.2020 18:29

program ml;
uses crt;
var x,i:integer;
    w,l:real;
begin
clrscr;
readln(x);
L:=x;
for i:=1 to x do                         begin
w:=w+1;
l:=x/w;
if frac(l) = 0 then writeln(l:2:0);
                                                end;
readkey;
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота