В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
мария2081
мария2081
08.10.2020 02:52 •  Информатика

Составить программы на языке паскаль для решения . 1. вычислить площадь прямоугольника и длину его диагонали, если стороны соответственно имеют длины 5 и 8 см. 2. написать программу, которая вычисляет площадь треугольника s, со стороной a=10 и высотой h=15. 3. вычислить площадь трапеции с высотой h=8 и основаниями a=10 и b=20.

Показать ответ
Ответ:
Кирвалидзе
Кирвалидзе
24.05.2020 22:03

Задача 1.

var

a,b,S,d: real;

begin

a:=5;

b:=8;

d:=sqrt(sqr(a)+sqr(b));

S:=a*b;

writeln('d = ',d);

writeln('S = ',S);

end.

Задача 2.

var

a,h,S: real;

begin

a:=10;

h:=15;

S:=1/2*a*h;

writeln('S = ',S);

end.

Задача 3.

var

a,b,h,S: real;

begin

a:=10;

b:=20;

h:=8;

S:=1/2*(a+b)*h;

writeln('S = ',S);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота