Составить схему алгоритма и написать программу вычисления суммы (произведения) конечного ряда. При разработке программы предусмотреть пропуск слагаемых (множителей), равных нулю или бесконечности.
Сначала все числа нужно привести к единой системе счисления.
11₂=3
11₈=9
11₁₆=17
Получается следующее: 3+9+11+17=3+20+17=20+20=40 (это в десятичной СС)
а) для перевода в двоичную СС мы последовательно делим число 40, пока остаток и частное не станет равным 0 или 1. Остаток от деления записываем в обратном порядке.
б) перевод целых десятичных чисел в любую другую системы счисления осуществляется делением числа на основание новой системы счисления (в нашем случае это 16) до тех пор, пока в остатке не останется число меньшее основания новой системы счисления. Новое число записывается в виде остатков деления, начиная с последнего.
а) 101000₂
б) 28₁₆
Объяснение:
Сначала все числа нужно привести к единой системе счисления.
11₂=3
11₈=9
11₁₆=17
Получается следующее: 3+9+11+17=3+20+17=20+20=40 (это в десятичной СС)
а) для перевода в двоичную СС мы последовательно делим число 40, пока остаток и частное не станет равным 0 или 1. Остаток от деления записываем в обратном порядке.
б) перевод целых десятичных чисел в любую другую системы счисления осуществляется делением числа на основание новой системы счисления (в нашем случае это 16) до тех пор, пока в остатке не останется число меньшее основания новой системы счисления. Новое число записывается в виде остатков деления, начиная с последнего.
Program zadacha;
const n=10;
var
a:array [1..n] of integer;
i,min,max,sum:integer;
begin
writeln('Введите элементы:');
for i := 1 to n do read(a[i]);;
max:=-10000; min:=10000;
for i:=i to n do
if (a[i]>max) then max := a[i];
writeln('Максимальное число в массиве: ',max);
for i:=1 to n do
if (a[i]<min) then min:=a[i];
writeln('Минимальное число в массиве: ',min);
for i := 1 to n do sum:=sum+a[i];
writeln('Сумма всех чисел массива = ',sum);
End.
Объяснение:
min ставим наибольшим, чтобы оно постепенно уменьшалось в сравнении. max ставим от наименьшего, чтобы оно увеличивалось в сравнении.
При суммировании необязательно обнулять переменную (в данном случае sum), т.к. у нас немного действий.