Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
vodzinskiyaleksandr
01.12.2022 20:19 •
Информатика
Составьте paskal-программу решение следующей : задан массив a(n).найти сумму и количество чётных отрицательных элементов этого массива
Показать ответ
Ответ:
ksusha6060606
01.10.2020 22:57
Const
n=10;
Var
a:array[1..n]of integer;
i,S,k:integer;
begin
for i:=1 to n do
begin
a[i]:=random(100)-50;
write(a[i]:4);
if (a[i] mod 2=0)and(a[i]<0)then
begin
s:=s+a[i];
k:=k+1;
end
end;
writeln;
writeln('S: ',s,' k:',k);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
viper998
16.04.2023 08:20
1страница содержит 50 строк по 40 символов книга содержит 200 страниц определить 1.онформационный объем страницы 2.информационый объем книги 3.сколько книг вместится...
mrden3333
03.02.2023 01:51
Разработать алгоритм для подсчёта факториала числа....
АполинарияТВ
28.07.2020 22:31
Примеры ситуаций в которых информация сохраняется (минимум 2)...
Suprunenko2007
24.01.2020 08:39
Сколько байт информации содержит сообщение объёмом 16 гбитответ- степень 2...
ZhEnYa9911
21.02.2021 22:01
Сообщение на тему- преимуществах машинно-независимых языков программирования перед машинно зависимыми языками...
alekseywindas
04.04.2023 10:08
Дано пятизначное число.получить из него трехзначное число.удалить сотни и десятки.составить программу....
Настя20767
01.10.2021 22:50
выберите ложные утверждения.(паскаль-записи) 1)все поля записи должны быть разных типов. 2)названия полей записи могут совпадать с именами переменных, констант и...
MiniCreeper55
16.02.2022 01:34
Послушай рассказ учителя и ответь на вапросы...
SASHA123741852
16.02.2022 01:34
718 кило-бат (кб) это много, средне, мало?...
foxi22
12.12.2020 02:17
718 кило-байт (кб) - это много, средне, мало?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
n=10;
Var
a:array[1..n]of integer;
i,S,k:integer;
begin
for i:=1 to n do
begin
a[i]:=random(100)-50;
write(a[i]:4);
if (a[i] mod 2=0)and(a[i]<0)then
begin
s:=s+a[i];
k:=k+1;
end
end;
writeln;
writeln('S: ',s,' k:',k);
end.