В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
VUNDURKIND1
VUNDURKIND1
22.04.2023 12:30 •  Информатика

Составьте программу дан массив чисел. определить количество элементов, находящихся в интервале от 1 до 12 и расположенных до максимального элемента массива.

Показать ответ
Ответ:
Yana2502
Yana2502
08.06.2020 19:28

C#

using System;

namespace ArrayMax

{

class Program

{

static void Main(string[] args)

{

int n;

Console.WriteLine("Введите количество элементов массива: ");

n = Convert.ToInt32(Console.ReadLine()); //вводим количество элементов Массива

Console.WriteLine();

int[] a = new int[n]; //выделяем память под массив

Random r = new Random();

for (int i = 0; i < n; i++)

{

a[i] = r.Next(0, 20); //заполняем массив рандомными числами от 0 до 20

}

for (int i = 0; i < n; i++)

{

Console.WriteLine(a[i]); //выводим массив

}

int max = a[0], maxIndex = 0;

for (int i = 0; i < n; i++)

{

if (max < a[i])

{

max = a[i];

maxIndex = i; //находим индекс максимального элемента

}

}

int count = 0; //счётчик для чисел между 1 и 12 до макс элемента

for (int i = 0; i <= maxIndex; i++)

{

if (a[i] >= 1 && a[i] <= 12) //если элемент >= 1 и <= 12, прибавляем счётчик

count++;

}

Console.WriteLine();

Console.WriteLine(count); //выводим количество числе от 1 до 12 до макс эл массива

Console.ReadKey();

}

}

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота