Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
tanyakozina00
01.02.2022 22:43 •
Информатика
Составьте программу, дано количество информации в битах. вывести в удобной форме в более крупных единицах. (до мб). пример вывода: 10240 бит = 1280 байт = 1,25 кб = 0,0012 мб
Показать ответ
Ответ:
Владимир328
04.10.2020 04:57
Var
n:integer;
begin
read(n);
write(n,' бит = ', n/8, ' байт = ', n/8192:0:2,' Кб = ',n/(8*sqr(1024)):0:4,' Мб');
end.
Альтернативное решение:
var
n: integer;
b, kb, mb: real;
begin
read(n);
b := n / 8;
kb := b / 1024;
mb := kb / 1024;
write(n, ' бит = ', b:0, ' байт = ', kb:0:2, ' Кб = ', mb:0:4, ' Мб');
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
20Iulia
19.11.2021 14:29
Дана программа на языке паскаль. программа определения весовой категории в зависимости от веса спортсмена. если вес спортсмена меньше 61, то «лёгкая категория» иначе «средняя...
FruitAPps
19.11.2021 14:29
Вводятся n целых чисел. найти сумму всех чисел....
Babka2002
15.06.2020 12:39
Домашнее задание«Наше будущеев наших руках Напиши небольшое эссе на тему «Наше будущее в наших руках» и набери его в текстовом редакторе....
narminanarminaovsozg
15.06.2020 12:39
Всё задание написано на фотографии. язык программирования С++...
polinakuznechov
18.05.2022 06:03
сделать программу на исполнителе по информатике...
МахаХей
04.06.2021 02:21
Объясните деление столбиком двузначное на двузначное, и трёхзначное на двухзначное.(Я малолетний, сорре) ...
angelochekzluk
09.03.2021 04:11
Что такое ритенута и как обозначается в музыке...
Единорог6663
16.09.2022 09:42
Инженерная графика . Нужно выполнить технический рисунок...
Ангелочек350
03.12.2020 01:38
1) ab=16 bc=24 ce=10 de=x 2)ab=y be=7 de=3 cd=5 найти х y по рисунку...
ГолубойРо
10.02.2020 13:20
Вии, воювати.получення букв йо чи322 I. Спишіть речення, уставляючи на місці крапок сполучення еБо та розкриваючи дужки. Підкресліть і поясніть вивчені орфограмаами,1. Тихо...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
n:integer;
begin
read(n);
write(n,' бит = ', n/8, ' байт = ', n/8192:0:2,' Кб = ',n/(8*sqr(1024)):0:4,' Мб');
end.
Альтернативное решение:
var
n: integer;
b, kb, mb: real;
begin
read(n);
b := n / 8;
kb := b / 1024;
mb := kb / 1024;
write(n, ' бит = ', b:0, ' байт = ', kb:0:2, ' Кб = ', mb:0:4, ' Мб');
end.