В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
sonyakaka332
sonyakaka332
03.02.2021 20:59 •  Информатика

Составьте программу дискриминанта так, чтобы а,b,с -задавались генератором случайных чисел (random); +эта программа должна включать в себя массив ( в писать по возможности с объяснением)

Показать ответ
Ответ:
nikolesyas
nikolesyas
11.06.2020 14:37

Var koef:array[1..3] as integer; 

d:real;

i:integer;

Begin

Randomize;

;Генерируем коэффициенты a b c

for i:=1 to 3  do

begin

koef[i]:=random(100);

end;

;Считаем дискриминант 

d:=koef[2]*koef[2]-4*koef[1]*koef[3];

;выводим ответ

Writeln(d:5:2);

end.

 

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота