В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
artur19912000
artur19912000
30.06.2022 15:59 •  Информатика

составьте программу для чтения отрывка из текста.Переключение его на Перевертыш и передача его на печать в том же варианте. Слово перевертыша переводится следующим образом: буквы, стоящие до первого гласного, перемещаются до конца слова и соединяются с окончанием quot; циусquot;. Например.
a)" кот в сапогах " -- " откциус вциус апогахсциус"
b) "пример перевода" -- " имерпрциус ереводапциус"

Показать ответ
Ответ:
sallyllyi
sallyllyi
13.10.2020 07:50

// PascalABC.Net

var vowel: set of char = ['а', 'у', 'о', 'ы', 'и', 'э', 'я', 'ю', 'ё', 'е'];

s, substr: string;

begin

  s := 'кот в сапогах';

  var words := s.Split(' ');

  for var i := 0 to words.length - 1 do

  begin

      for var j := 1 to words[i].Length do

          if words[i][j] in vowel then

          begin

              substr := Copy(words[i], 1, j-1);

              Delete(words[i], 1, j-1);

              words[i] += substr;

              break;

          end;

      words[i] += 'циус';

  end;

  writeln(words.JoinIntoString(' '));

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота