В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
uylia144348
uylia144348
06.12.2022 20:07 •  Информатика

Составьте программу для нахождения среднего арифметического двухзначных чисел кратных 3

Показать ответ
Ответ:
sanadakim
sanadakim
01.10.2020 16:59
Допустим дана последовательность числе из n элементов
Pascal
var
 mas:array[1..100] of integer;
 n2,sum,i,n:intger;
begin
 readln(n);
 sum:=0;
 n2:=0;
 for i:=1 to n do
  read(mas[i]);
 for i:=1 to n do
 begin
  if (mas[i] mod 3 = 0) and (mas[i]>9) and (mas[i]<100) then
  begin
   n2:=n2+1;
   sum:=sum+mas[i];
  end;
 end;
 writeln(sum/n2);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота