В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
санс
санс
11.03.2020 16:57 •  Информатика

Составьте программу для pascal abc, решающую следующую . у продавца имеются гири весом 1, 2, 5 кг. наберите минимальное кол-во гирь для взвешивания n кг.

Показать ответ
Ответ:
Синуэлла
Синуэлла
06.07.2020 22:38
Program z1;
        var n:integer;
        s1,s2,s5:integer;
begin
        write('n=');readln(n);
        s5:=n div 5;n:=n mod 5;
        s2:=n div 2;s1:=n mod 2;
        writeln('5 kg-',s5,';   2 kg-',s2,';   1 kg-',s1);
        readln
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота