В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
allalal1
allalal1
15.11.2020 02:16 •  Информатика

Составьте программу для решения одной из следующих , которая запрашивает значение элементов одномерного числового массива а и подсчета суммы элементов массива, меньших своего номера.

Показать ответ
Ответ:
SwanBlack
SwanBlack
03.10.2020 17:29
//Pascal ABC.NET v3.1 сборка 1219

Const
 n=5;

Var
 a:array[1..n] of integer;
 i,s:integer;
begin
 for i:=1 to n do
  begin
   readln(a[i]);
   if a[i]<i then s:=s+a[i];
  end;
 writeln(s);
end.

Пример ввода:
2
2
1
1
2
Пример вывода:
4
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота