В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
JoyGames14982
JoyGames14982
05.01.2022 17:32 •  Информатика

Составьте программу для решения следующей . введите с клавиатуры два числа: n и m. если оба числа больше 100, то замените каждое из них меньшим и выведите результаты на экран. если первое число положительное, а второе отрицательное, то уменьшите их в два раза и выведите результаты. иначе, найдите и выведите среднее арифметическое этих чисел.

Показать ответ
Ответ:
yanasmailik
yanasmailik
15.07.2020 19:21
Program A1;
var
N,M,K:real;
Begin
writeln('Введите числа N и M');
readln(N,M);
If N>100 and M>100 then
N:=N-1;
M:=M-1;
writeln(M,N);
If N>0 and M<0 then
N:=N/2;
M:=M/2;
writeln(N,M)
Else
K:=0;
K:=(M+N)/2;
writeln(K);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота