В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
ritikdf345
ritikdf345
17.07.2020 04:57 •  Информатика

Составьте программу для решения следующей . введите с клавиатуры три числа: а, в, с. если а> в> c> 0, то замените все числа их квадратами и выведите результаты на экран. если они отрицательны и не равны между собой, то каждое число замените наибольшим из них и выведите результаты. иначе, найдите и выведите их сумму.

Показать ответ
Ответ:
Скримлучший
Скримлучший
07.07.2020 12:42
Var a,b,c,max:real;
begin
write('Введите a, b и c: ');
readln(a,b,c);
if (a>b) and (b>c) then
  begin
  a:=a*a;
  b:=b*b;
  c:=c*c;
  writeln('a=',a,', b=',b,', c=',c);
  end
  else if (a<0) and (b<0) and (c<0) and (a<>b) and (a<>c) and (b<>c) then
    begin
    max:=a;
    if b>max then max:=b;
    if c>max then max:=c;
    a:=max;
    b:=max;
    c:=max;
    writeln('a=',a,', b=',b,', c=',c);
    end
    else writeln(a+b+c);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота