В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
anya2403
anya2403
21.12.2022 14:43 •  Информатика

Составьте программу для решения задачи на языке Pascal:

1. Найти значение функции а=. Обратите внимание, что выражение записано под знаком корня, значит должно выполняться определенное условие. Значения переменных ввести с клавиатуры.

2. Ввести две переменные и найти разность большей и меньшей из них.

Рассмотреть оба случая, т. е. большей может быть и одна и другая переменная. Переменные нужно сравнить и выполнить вычисления, когда одна из них больше, иначе – вторая будет больше.

Ввести также дополнительную переменную, которая будет обозначать результат вычисления.

Показать ответ
Ответ:
samikzaki
samikzaki
03.08.2020 10:57

Задача 1:

program P1;

var a,b: real;

begin

write('b = '); readln(b);

if 32 - b < 0 then writeln('error') else begin

a := sqrt(32 - b);

writeln(a:0:4);

end;

end.

Задача 2:

program P2;

var a,b,result: real;

begin

write('a = '); readln(a);

write('b = '); readln(b);

if a > b then result := a - b else result := b - a;

writeln(result:0:4);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота