Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
yuriayato
11.06.2020 10:04 •
Информатика
Составьте программу для ввода с клавиатуры в массив 10 целых чисел и вывода первых 5-и чисел в обратном порядке в первую строку, во вторую строку – последние четыре числа в обычном порядке, а в третьей строке – первый и девятый элементы массива (
Показать ответ
Ответ:
Варя11011
04.10.2020 00:55
Var b:integer;
a: array [0..9] of integer;
begin
randomize;
for b:=0 to 9 do begin
read(a[b]);
end;
for b:=4 downto 0 do begin
write(a[b],' ');
end;
writeln('');
for b:=6 to 9 do begin
write(a[b],' ');
end;
writeln('');
for b:=0 to 9 do begin
if ((b=0)or (b=8)) then write(a[b],' ');
end;
writeln('');
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
andreymarkov2090
24.10.2021 03:31
Які твердження описують відмінності між розширеними фільтрами та запитами? у запиті можна сортувати результати, а у фільтрi - Hi фільтр можна застосувати тільки...
catarshaninp08iio
27.04.2021 04:34
ДО ІТЬ ів Ось задача: задано число. вивести повідомлення чи воно кратне 5? задано 2 числа. вивести так якщо добуток цих чисел є додатнім, та ні в зворотньому випадку....
Qudipue1
07.10.2021 14:32
Вирустардың таралу жолдары...
катейка22
11.07.2021 19:38
Коаксиальный разъем с вмонтированным , сопротивление которого равно волновому сопротивлению кабеля, называется 1) коннектор 2) терминатор 3) активатор 4) адаптер...
ДианаЛаймова2003
11.07.2021 19:38
Мощность некоторого алфавита 15 символов .все символы кодируются одинаковым минимально возможным количеством битов.каков информационный объем текста из 1024 символов?...
FYBKF
11.07.2021 19:38
Умышленные угрозы подразделяются на: 1) случайные и пассивные 2) случайные, пассивные и активные 3) случайные и активные 4) пассивные и активные 5) случайные и непреднамеренные...
Bogataer1
11.07.2021 19:38
На c++ дана целочисленная матрица. определить: а) номер первой из строк, содержащей хотя бы один положительный элемент б) характеристику каждой строки матрицы. характеристикой...
yanademchenko38
11.07.2021 19:38
Изображение имеет размер 2048*128 пикселей .каждый пиксель кодируется 1 байтом .каков информационный объем изображения? 22: 241)1 мегабайт2)2 мегабита3)256 килобайта4)2^21...
prostonick111237
12.10.2020 06:31
Найти значение y=3*cos(x/2)+4 на интервале [2; 4] с шагом h=0,2, используя цикл с предусловием....
KoNetik2020
12.10.2020 06:31
Рост ребенка на начало года составляет 120 см. за месяц он подрастает на 2%. за сколько месяцев его рост станет больше или равным 150 см....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
a: array [0..9] of integer;
begin
randomize;
for b:=0 to 9 do begin
read(a[b]);
end;
for b:=4 downto 0 do begin
write(a[b],' ');
end;
writeln('');
for b:=6 to 9 do begin
write(a[b],' ');
end;
writeln('');
for b:=0 to 9 do begin
if ((b=0)or (b=8)) then write(a[b],' ');
end;
writeln('');
end.