В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
sofa286
sofa286
20.11.2020 12:24 •  Информатика

Составьте программу. для вводимых с клавиатуры чисел определить количество четных и сумму нечетных чисел. ввод прекращается когда пользователь вводит цифру 0

Показать ответ
Ответ:
mantsigina
mantsigina
31.08.2020 23:48
Var A,c:longint;
    S:real;
Begin
c:=-1;
S:=0;
Repeat
Read(A);
if A mod 2 = 0 then c:=c+1
else S:=S+A;
Until A = 0;
WriteLn('Количество чётных: ',c);
WriteLn('Сумма нечётных: ',S);
End.

Пример работы программы:

1 2 3 4 5 6 7 8 9 10 0
Количество чётных: 5
Сумма нечётных: 25
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота