В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
gagarinken
gagarinken
07.04.2023 12:37 •  Информатика

Составьте программу для вычисления косинусов углов треугольника со сторонами a, b, c. указание. примените теорему косинусов: c2=a2 + b2 -2ab * cos α

Показать ответ
Ответ:
ленок216
ленок216
07.09.2020 11:45
Var a,b,c,cosa, cosb, cosc:real; 
begin 
writeln('Введите стороны треугольника АВС'); 
read(a,b,c); 
cosa:=(sqr(b)+sqr(c)-sqr(a))/(2*b*c); 
cosb:=(sqr(c)+sqr(a)-sqr(b))/(2*c*a); 
cosc:=(sqr(a)+sqr(b)-sqr(c))/(2*a*b); 
writeln('Косинус угла А = ', cosa, ' Косинус угла В =', cosb,' Косинус угла C =', cosc); 
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота