В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Nastyaninisvn
Nastyaninisvn
14.08.2022 06:05 •  Информатика

Составьте программу для вычисления произведения целых чисел, их среднее арифметическое до тех пор пока не будет введён 0 используя цикл repeat

Показать ответ
Ответ:
dhjejdj
dhjejdj
06.10.2020 11:05
 Var
   A,S,P:real;
   k:integer;
Begin
S:=0;
P:=1;
k:=-1;
Repeat
Read(A);
if A <> 0 then P:=P*A;
S:=S+A;
k:=k+1;
Until A = 0;
WriteLn('P = ',P);
WriteLn('Sr = ',S/k);
ReadLn
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота