В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
daniil0723
daniil0723
25.09.2022 12:45 •  Информатика

Составьте программу для вычисления суммы чисел кратных 8 вдиапазоне от а до b. java

Показать ответ
Ответ:
амир295
амир295
08.10.2020 01:06
Import java.util.Scanner;

class Strange
{
    public static void main (String[] args)
    {
        Scanner sc = new Scanner(System.in);
        int a = sc.nextInt();
        int b = sc.nextInt();
        sc.close();
        int r = a % 8;
        if (r != 0) a += 8 - r;
        int s = 0;
        for (int i=a; i <= b; i+=8) s += i;
        System.out.println("Сумма:" + s);
    }
}

Составьте программу для вычисления суммы чисел кратных 8 вдиапазоне от а до b. java
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота