В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
zalehorosaj
zalehorosaj
01.07.2020 20:40 •  Информатика

Составьте программу для вычисления сумсы факториалов четных чисел от m до n ( через функцию или процедуру, если не сложно с объяснением)

Показать ответ
Ответ:
chovganirina
chovganirina
02.07.2022 19:51
// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
begin
  var n:=ReadInteger('Кол-во элементов:');
  var a:=ArrRandomReal(n,-10,20); a.Println;
  Writeln('С округлением если |x|<1');
  for var i:=0 to n-1 do
    if abs(a[i])<1 then a[i]:=Round(a[i]);
  a.Println
end.

Тестовое решение:
Кол-во элементов: 10
-0.751956142835299 5.95022566427953 3.58861613254464 7.42331713783709 -4.75036238075717 -9.41228387384316 -0.700975591643235 3.85500546258642 -1.94321916994789 19.3021338336645
С округлением если |x|<1
-1 5.95022566427953 3.58861613254464 7.42331713783709 -4.75036238075717 -9.41228387384316 -1 3.85500546258642 -1.94321916994789 19.3021338336645
0,0(0 оценок)
Ответ:
tomlinsondarya
tomlinsondarya
05.07.2022 12:06
Для того, чтобы узнать в каком подъезде находится квартира, разделим ее номер на количество квартир в подъезде, на 36. Запомним частное и остаток от деления. Пусть, к примеру, нам дана квартира 85. Делим на 36. Получаем частное 2 и в остатке 13. 2 - это номер подъезда. Теперь разделим 13 на 4 (число квартир на этаже), запомним частное и остаток. В результате получим 3 и остаток 1. Значит, наша квартира на 3-м этаже, и если номера квартир идут слева направо, то квартира будет крайняя слева.

Итак, квартира с номером 85 находится во втором подъезде, на 3-м этаже нашего дома.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота