В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
russalinagaras
russalinagaras
02.05.2022 00:17 •  Информатика

Составьте программу для выселения величины s по формуле ​
сделайте скриншот в паскале

Показать ответ
Ответ:
sasha210803
sasha210803
03.04.2020 20:59
#include <stdio.h>      /* printf, scanf, puts, NULL */
#include <stdlib.h>     /* srand, rand */
#include <time.h>       /* time */
#include <iostream>
using namespace std;
int main (){
int i,n,c;
printf ("Введите n: ");
scanf ("%d",&n);
int digit[n];
srand (time(NULL));
c=0;
for(i=1;i<=n;i++)  {
digit[i] = (int)(rand()-rand());
cout<<"Число "<<i<<" = "<<digit[i]<<'\n';
if(digit[i]>=0)c++;
}
cout<<"Количество всех неотрицательных элементов: "<<c<<"\n";
return 0;
}
0,0(0 оценок)
Ответ:
vprasckowya
vprasckowya
03.04.2020 20:59
Красивенький вывод уж сам.
 
#include <iostream>
using namespace std;

int main() {
    cout << "n = ";
    int n, not_null;
    cin >> n;
    int *mass = new int [n];
    //Заполнение и вывод массива
    for (int i = 1; i <= n; i++) {
        mass[i] = rand()-rand();
        cout << "mass["<<i << "] = "<<mass[i] << endl;
        //Определяем положительные числа и считаем их
        if (mass[i] > 0) {
            not_null++;
        };
    }
   

    cout << "n > 0 = " << not_null << endl;

    system("pause");
   return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота