Составьте программу для задачи: Дан массив целых чисел, состоящий из 15 элементов. • заполните массив любым удобным для вас найдите сумму элементов массива, имеющих нечетное значение
// Коммент: случайное число в паскале всегда генерируется от 0 до заданного но нам необходимо от 1000, поэтому в цикле repeat...until оно будет генерироваться до тех пор, пока не станет > 999
Repeat x := Random(RndLimit) until x > 999;
writeln ('Random X= ', x);
SumX := SumX + (x div 1000) + (x mod 1000 div 100) + (x mod 1000 mod 100 div 10) + (x mod 1000 mod 100 mod 10);
writeln ('Sum = ', SumX);
end.
запускаем
Free Pascal Compiler version 2.6.2-8 [2014/01/22] for x86_64
Copyright (c) 1993-2012 by Florian Klaempfl and others
Объяснение:
program Randomizer;
const
RndLimit = 10000;
var
x, SumX : integer;
begin
SumX := 0;
// Коммент: случайное число в паскале всегда генерируется от 0 до заданного но нам необходимо от 1000, поэтому в цикле repeat...until оно будет генерироваться до тех пор, пока не станет > 999
Repeat x := Random(RndLimit) until x > 999;
writeln ('Random X= ', x);
SumX := SumX + (x div 1000) + (x mod 1000 div 100) + (x mod 1000 mod 100 div 10) + (x mod 1000 mod 100 mod 10);
writeln ('Sum = ', SumX);
end.
запускаем
Free Pascal Compiler version 2.6.2-8 [2014/01/22] for x86_64
Copyright (c) 1993-2012 by Florian Klaempfl and others
Target OS: Linux for x86-64
Compiling main.pas
Linking a.out
21 lines compiled, 0.1 sec
Random X= 5488
Sum = 25
1)
#include <iostream>
#include <cmath>
#include <vector>
#include <algorithm>
#include <set>
using namespace std;
signed main() {
srand(time(NULL));
int n;
cin >> n;
int a[n];
for(int i = 0; i < n; i++)
a[i] = rand() % 5 + 1;
vector<int> ans;
for(int i = 0; i < n; i++)
{
cout << a[i] << " ";
if(a[i] == a[0])
ans.push_back(i);
}
cout << "\n";
for(auto i: ans)
cout << i << " ";
}
2)
#include <iostream>
#include <cmath>
#include <vector>
#include <algorithm>
#include <set>
using namespace std;
signed main() {
int n,k;
cin >> n >> k;
int a[n];
vector<int> ans;
for(int i = 0; i < n; i++)
{
cin >> a[i];
if(a[i] % k == 0)
ans.push_back(a[i]);
}
for(auto i: ans)
cout << i << " ";
}
3)
#include <iostream>
#include <cmath>
#include <vector>
#include <algorithm>
#include <set>
using namespace std;
signed main() {
int n,z;
cin >> n >> z;
int a[n];
for(int i = 0; i < n; i++)
{
cin >> a[i];
a[i] = min(a[i],z);
}
for(auto i: a)
cout << i << " ";
}