В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
TheKristinasGames
TheKristinasGames
21.05.2022 07:18 •  Информатика

Составьте программу Если цена товара С меньше
1000, то определим объем реализации М
(количество проданного товара), иначе определить
сумму выручки S
и количество проданного товара N.

Показать ответ
Ответ:
1337zezar1
1337zezar1
23.09.2022 20:50

Кибернетика

Объяснение:

В середине века выдающийся американский учёный Норберт Винер (1894−1964) , изучавший различные технические и биологические системы, установил, что управление в них осуществляется по общей схеме. Винер считается основоположником науки об управлении — кибернетики.

Существует большое количество различных определений понятия «кибернетика», однако все они сводятся к тому, что кибернетика — это наука, изучающая общие закономерности строения сложных систем управления и протекания в них процессов управления. Так как любые процессы управления связаны с принятием решений на основе получаемой информации, то кибернетику часто определяют ещё и как науку об общих законах получения, хранения, передачи и преобразования информации в сложных управляющих системах.

0,0(0 оценок)
Ответ:
Magma11
Magma11
01.06.2021 21:50

Функция strlen() возвращает длину строки, то есть strlen(str) - длина строки str. В массиве выделено место для 101 символа, так как по условию максимальная длина введенной строки - 100 символов, но еще одно место в массиве нужно для нуль-терминатора(\0), иначе программа не сможет успешно работать со строкой и для некоторых входных данных будет выдаваться ошибка. Так как str - массив символов типа char, то можно обращаться к каждому элементу массива с индекса, что и происходит в цикле for.

Объяснение:

#include <iostream>

using namespace std;

int main()

{

char str[101];

cin >> str;

for (int i = 0; i < strlen(str); i++) {

 cout << str[i];

 if (i != strlen(str)-1) cout << '*';

}

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота