В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
slaviktaran00
slaviktaran00
28.02.2022 09:40 •  Информатика

Составьте программу которая будет определять любые введённые данные в тексте. постройте блок схему к этой программе ​

Показать ответ
Ответ:
juliacollins5
juliacollins5
28.05.2022 01:37

1) 2*6^0 + 0*6^1 + 1*6^2 + 5*6^3

2) 3 единицы

3) 24D

4) 6

5) 2 раза

Объяснение:

2) 37_{10} = 100101_{2}

3) Переводим число 589_{10} в 16-ичную систему счисления, для этого делим его на 16 и запоминаем остаток. Затем результат деления также делим на 16 и запоминаем остаток. Повторяем эти действия до тех пор, пока частное не будет равно 0:

589 : 16 = 36, остаток 13

36 : 16 = 2, остаток 4

2 : 16 = 0, остаток 2

Затем записываем остатки от деления в обратном порядке: 2 4 13

Заменяем числа больше 9 на буквы

(10 - A; 11 - B; 12 - C; 13 - D; 14 - E; 15 - F)

Результат: 24D_{16}

4)

234_{x} = 94_{10}\\4 * x^0 + 3 * x^1 + 2 * x^2 = 94\\4 + 3x + 2x^2 = 94\\2x^2 + 3x - 90 = 0\\x = 6

5) Посчитаем от 1 до 10 в  6-ичной системе счисления:

1 2 3 4 5 10 11 12 13 14

0,0(0 оценок)
Ответ:
Smartfone
Smartfone
25.11.2022 20:33

ЯП: С++

#include <iostream>

int main() {

const int N = 5;

int arr[N][N] = {1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25}; // создаем и заполняем двумерный массив 5x5

for (int i = 0; i < N; i++) // выводим на экран 2-мерный массив;

{

 for (int j = 0; j < N; j++)

 {

  std::cout << arr[i][j] << "\t";

 }

 std::cout << std::endl;

}

std::cout << "Result #1: ";

for (int i = 0; i < N; i++) // вывод в консоль главной диагонали

{

 std::cout << arr[i][i] << "\t";

}

std::cout << "\nResult #2: ";

for (int i = 0; i < N; i++) // вывод в консоль побочной диагонали

{

 std::cout << arr[i][N - 1 - i] << "\t";

}

return 0;

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота