В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
4moebanoe
4moebanoe
30.03.2023 20:12 •  Информатика

Составьте программу, которая для целого числа k (от 1 до 99), введенного вами, напечатает фразу «Мне k лет», при этом в нужных случаях слово «лет» заменяя на слово «год» или «года».

На языке Паскаль
С использованием оператора switch, case

Показать ответ
Ответ:
Sergay121
Sergay121
06.08.2020 15:53

var

Age : integer;

begin

Repeat

Write('Введите Ваш возраст: ');

Readln(Age);

until Age in [1..99];

if Age in [10..20] then Writeln('Мне ', Age, ' лет') else

case Age mod 10 of

1: Writeln('Мне ', Age, ' год');

2, 3, 4 : Writeln('Мне ', Age, ' года');

0, 5..9 : Writeln('Мне ', Age, ' лет');

end;

end.

0,0(0 оценок)
Ответ:
STALKER147
STALKER147
06.08.2020 15:53

// PascalABC.NET

begin

 var n := ReadInteger('Введите возраст (1-99):');

 if not (n in 1..99) then

   Print('Неверный возраст')

 else if n in 10..20 then

   Print('Мне', n, 'лет')

 else

   case n mod 10 of

     1: Print('Мне', n, 'год');

     2..4: Print('Мне', n, 'года');

   else Print('Мне', n, 'лет')

   end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота