В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Дони1214
Дони1214
12.03.2021 22:11 •  Информатика

Составьте программу , которая формирует массив из 10 целых чисел значения которых лежат в интервале от - 10 до 10 ( [ 10: 10] ) . программа должна выводить на экран исходный массив затем преобразовать элементы массива , увеличивая в два раза положительные элементы , а для отрицательных элементы менять знак на противоположный . выведите на экран преобразованный массив . в паскале !

Показать ответ
Ответ:
nikusy2005
nikusy2005
09.10.2020 19:28

const n=10;

var a:array[1..n] of integer;

i: integer;

begin

for i:=1 to n do

begin

a[i]:=random(21)-10;

write (a[i]:3,' ');

if a[i]>0 then a[i]:=a[i]*2;

if a[i]<0 then a[i]:=-a[i]

end;

writeln;

for i:=1 to n do write (a[i]:3,' ')

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота