В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
ChristenChy
ChristenChy
20.03.2022 23:05 •  Информатика

Составьте программу , которая формирует массив из 12 случайных целых чисел из промежутка [160..180]. и уменьшает в 2 раза числа меньше среднего арифметического а больше среднего арифметического увеличивается в 2 раза . по информатике

Показать ответ
Ответ:
sanek2031
sanek2031
31.08.2020 15:18
from random import randint
A = [randint (160, 181) for i in range(12)]
srznach = 0
print(A)
for i in range (12):
        srznach= srznach + A[i]
srznach = srznach/12
print(srznach)
for i in range (12):
        if A[i] <srznach:
                A[i] = A[i]/2
        else:
                A[i] = A[i]*2
print(A)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота