В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
abeloglazova891
abeloglazova891
22.02.2020 00:11 •  Информатика

Составьте программу, которая формирует массив из 12 случайных чисел на промежутке от -40 до 10 и находят элементы, большие -10 и меньше 5

Показать ответ
Ответ:
gritana
gritana
26.05.2020 17:48

Program Program1;
Var
i:integer;
a:array [1..12] of integer;
begin
randomize;
for i:=1 to 12 do
a[i]:=random(51)-40;
writeln;
writeln('Элементы больше -10:');
for i:=1 to 12 do
if a[i]>-10 then write('a[',i,']=',a[i],', ');
writeln;
writeln('Элементы меньше 5:');
for i:=1 to 12 do
if a[i]<5 then write('a[',i,']=',a[i],', ');
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота