В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Виктор338
Виктор338
31.05.2023 21:15 •  Информатика

Составьте программу, которая формирует массив из 15 случайных целых чисел, принадлежащих промежутке [-20;20] вычислять сумму положительных

Показать ответ
Ответ:
evgen16112000
evgen16112000
11.11.2020 20:13

На паскале:

const

 n=15;

var

 a: array [1..n] of integer;

 sum,i:integer;

begin

 randomize;

 sum:=0;

 for i:=1 to n do

   begin

     a[i]:=random(41)-20;

     write(a[i]:4);

     if a[i]>0 then

       sum:=sum+a[i];

   end;

 writeln;

 write('sum: ',sum);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота