В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Phoenix511
Phoenix511
26.11.2022 06:57 •  Информатика

Составьте программу которая формирует массив из 16 случайных чисел от -20 до 20 и: а) находит элементы с нулевыми значениями б) находит индексы четных элементов в) подсчитывает количество отрицательных элементов г) определяет, есть ли в этом массиве хотя бы одно число, кратное трем д) находит в этом массиве индексы элементов, значения которых кратны трем . на экран выводятся исходный массив и найденные элементы

Показать ответ
Ответ:
fourkovioxk812
fourkovioxk812
02.10.2020 04:11
Const n=15;
Var a:array[1..n]  of integer;
i,indx,k,tr,indxx:integer;
Begin 
Randomize; 
 For i:=1 to n do  begin
  A[i]:=Random(40)-20; 
 Write(a[i],' '); 
   end; 
       Writeln; 
   write('0 имеет номер: '); 
     For i:=1 to n do   
Begin
 If A[i]=0 thenwrite(i);
 end;
Writeln;
indx:=0; 
 For i:=1 to n do 
  Begin
   If a[i] mod 2=0 then 
  begin 
  indx += 1; 
 a[indx]:=a[i]; 
  end; 
 end; 
    Write('Индекс четных элементов: '); 
 For i:=1 to indx do 
 write(a[i],' ');   
   For i:=1 to n do
    Begin 
   If A[i]<0 then
      Begin   
  inc(k);      
 end;      
   end;   
 Writeln;
 Writeln('Кoличество отрицательных элементов: ',k);
 For i:=1 to n do
  Begin 
 If A[i] mod 3=0 then 
 tr:=a[i];
  end; 
 Writeln('Кратное трем ',tr); 
   indxx:=0; 
 writeln('Индексы кратны 3: '); 
  For i:=1 to n do 
  Begin 
  If a[i] mod 3=0 then 
  begin   
   indxx += 1; 
 a[indxx]:=a[i];
   write(' ',a[i]); 
    end;   
 end;    
  end.  
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота