В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
xuligan79
xuligan79
12.01.2023 01:46 •  Информатика

Составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20, и производит одно из следующих вычислений: сумму чисел,кратных 3

Показать ответ
Ответ:
маруська62
маруська62
21.06.2020 15:55
#include <stdio.h>
#include <conio.h>
#include <stdlib.h>
#include <ctime>
main()
{     
int b=0,a[40],k=40,i;     
srand(time(0));     
 for (i=0;i<k;i++){         
a[i]=rand()% 21;         
printf("%3d",a[i]);         
 }     
for (i=0;i<k;i++){       
if ((a[i]%3)==0){       
 b+=a[i];   
 }  
 }            
 printf("\n%d",b);       
 getch();       
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота