В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
VladIslaV231678
VladIslaV231678
23.11.2020 14:13 •  Информатика

Составьте программу, которая формирует массив из 40 случайных чисел от 0 до 20 и вычисляет: а) среднее арифметическое нечетных чисел б) сумму чисел, не превышающих 10 в) сумму чисел, кратных 3 на экран выводятся исходные значения и результаты вычислений. только а, б и в нужно написать как отдельные , а не как одна. , . , завтра сдавать!

Показать ответ
Ответ:
Salina1904
Salina1904
21.06.2020 16:53
A)
program a1;
uses crt;
var m:array[1..40]of integer;
i:byte;
a,ka:integer;
begin
clrscr;
a:=0;ka:=0;
for i:=1 to 40 do
begin
 m[i]:=random(21);
 if m[i] mod 2<>0 then
 begin
 ka:=ka+1;
 a:=a+m[i];
 end;
 end;
for i:=1 to 40 do  if i=1 then write('M[',m[i],',')   else  if i=40 then writeln(m[i],']')   else  write(m[i],',');
writeln('Среднее арифметическое нечетных чисел=',a/ka);
end.
b)
program b1;
uses crt;
var m:array[1..40]of integer;
i:byte;
b:integer;
begin
clrscr;
for i:=1 to 40 do
begin
 m[i]:=random(21);
 begin
 if m[i]<=10 then b:=b+m[i];
 end;
 end;
for i:=1 to 40 do  if i=1 then write('M[',m[i],',')   else  if i=40 then writeln(m[i],']')   else  write(m[i],',');
writeln('Сумма чисел не превышающих 10=',b);
end.
в)
program v1;
uses crt;
var m:array[1..40]of integer;
i:byte;
c:integer;
begin
clrscr;
for i:=1 to 40 do
begin
 m[i]:=random(21);
 begin
if m[i] mod 3=0 then c:=c+m[i];
 end;
 end;
 for i:=1 to 40 do
 if i=1 then write('M[',m[i],',')
 else
 if i=40 then writeln(m[i],']')
 else
write(m[i],',');
writeln('Сумма чисел кратных 3 = ',c);
end.
0,0(0 оценок)
Ответ:
SeViK02
SeViK02
21.06.2020 16:53
1)
var a: array [1..40] of integer;
    i, s1, s2: integer;
begin
     for i := 1 to 40 do
     begin
          a[i] := random(20);
          writeln('a[', i, '] => ', a[i]);
          if (a[i] mod 2 = 1) then
          begin
               s1 := s1 + a[i];
               inc(s2);
          end;
     end;
     writeln(s1 / s2);
end.

2)
var a: array [1..40] of integer;
    i, q: integer;
begin
     for i := 1 to 40 do
     begin
          a[i] := random(20);
          writeln('a[', i, '] => ', a[i]);
          if (a[i] <= 10) then q := q + a[i];
     end;
     writeln(q);
end.

3)
var a: array [1..40] of integer;
    i, w: integer;
begin
     for i := 1 to 40 do
     begin
          a[i] := random(20);
          writeln('a[', i, '] => ', a[i]);
          if (a[i] mod 3 = 0) then w := w + a[i];
     end;
     writeln(w);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота