В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
lalala106
lalala106
23.02.2022 20:21 •  Информатика

Составте программу, которая формирует массив из 5 целых чисел,элементы массива вводятся вручную с клавиатуры. найдите максимальный элемент в массиве. ответ вывести в формате "мах=".

Показать ответ
Ответ:
rachik141516
rachik141516
07.10.2020 10:51
//Pascal
var
  A: array[1..5] of integer;
  i: byte;
  MAX: integer;
begin
writeln('Заполнение массива.');
for i := 1 to 5 do
begin
  write('A[',i,'] = '); readln(A[i]);
end;
MAX := A[1];
for i := 1 to 5 do
  begin
    if A[i] > MAX then MAX := A[i];
    write(A[i]:4);
  end;
writeln;
writeln('Максимальный элемент в массиве = ', MAX);  
readln;
end. 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота