Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Вероника5577
06.06.2020 09:46 •
Информатика
Составьте программу, которая формирует массив из 7 случайных целых чисел из [-20,20] и выводит модуль отрицательных элементов, а положительные оставляет без изменений. на экран выводит исходный и преобразованный массив.
Показать ответ
Ответ:
ученикB
04.10.2020 12:38
// PascalABC.NET 3.2, сборка 1341 от 20.11.2016
begin
var a:=ArrRandom(7,-20,20); a.Println;
a:=a.Select(x->abs(x)).ToArray; a.Println
end.
Пример
-9 17 6 1 20 9 -14
9 17 6 1 20 9 14
0,0
(0 оценок)
Популярные вопросы: Информатика
kfkkffkdkd
03.01.2020 23:17
Жители планеты альфа отправили на землю сообщение ,записанное с всех символов используемого ими алфавита : мклкмнонопрост! определите информационный объём этого сообщения...
nmh788
03.01.2020 23:17
По информатике, 9 класс 1.врач стоматолог принимает пациентов с 8 утра до 2х часов дня. на каждого пациента отводится по 30 минут. какое количество информации содержит сообщение...
kalishevij99
18.02.2023 10:59
Модель которая может изпользоваться для составления прогноза погоды, называется: 1.художественное описание природы 2.график средних температур 3.физическая карта4. глобус...
ufkvkvkg
21.07.2020 02:12
К какому виду программ относится электронная таблица Excel a) Системные программыб) Системы программированияв) Прикладные программыг) Обучающие программыд) Игрые) Мультимедиа...
andreygavrilov
21.01.2021 08:52
Составить блок-схему по готовой программе. Program zadacha; Var K, Min: real, N: integer; Begin Min:=0; N:=0; While N = 5 do Begin Write ( Введите число ); Readln (K); IF min...
DashaHB16
29.03.2020 01:08
Вклассе 110010(в 2-чной) девочек 1010(в 2-чной) мальчиков.сколько учеников в классе...
nazarenkolavrenyuk
09.06.2020 09:24
Как повлияло географическое положение на особенности культуры народов Италии и Испании?...
dinka1820
01.02.2022 11:43
Задание 2. Исправьте ошибки. 1. ... Он был задеpжан за то, что идя по улице, нецензуpно удивлялся шиpине впеpеди идущей женщины... 2. ... В бюро судебно-медицинскои экспертизы...
viktoria168
01.02.2022 11:43
ТЕКСТ ЗАДАНИЯ 3. Берілген сөздердің синонимін тапБұрынғыдан Ойда Жарыс ...
лис8889
02.01.2021 03:44
Вторыми лицами в государстве гуннов после шаньюя являлись его близкие родственники, которые носили титул: * каган туменбасы джабгу гуньмо...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
begin
var a:=ArrRandom(7,-20,20); a.Println;
a:=a.Select(x->abs(x)).ToArray; a.Println
end.
Пример
-9 17 6 1 20 9 -14
9 17 6 1 20 9 14