В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Составьте программу, которая формирует массив из десяти случайных целых чисел от 100 до 150 и увеличивает в два раза числа, кратные 5, а остальные уменьшает в 2 раза

Показать ответ
Ответ:
Hhhhhhhhelppppp
Hhhhhhhhelppppp
04.10.2020 22:18
#include <iostream>
using namespace std;

int main() {
const int SIZE = 10;
int a[SIZE];
size_t i;
for(i = 0; i < SIZE; i++) {
a[i] = rand() % 51 + 100;
cout << "a[" << i << "] = " << a[i] << '\n';
if (a[i] % 5 == 0)
a[i] = 2* a[i];
else
a[i] = (int) a[i]/2;
}
cout << "" << '\n';
for(i = 0; i < SIZE; i++) {
cout << "a[" << i << "] = " << a[i] << '\n';
}
return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота