В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
arinapes30
arinapes30
12.09.2020 22:25 •  Информатика

Составьте программу, которая формирует массив из пятнадцати случайных целых чисел от -20 до 20 и отрицательные числа возводит в квадрат, а из неотрицательных извлекает квадратный корень.

Показать ответ
Ответ:
SofiaQueen
SofiaQueen
02.10.2020 04:13
Program rp1;
uses crt;
var a: array [1..15] of integer; i: integer;
begin
clrscr;
randomize;a[i]:=random (41)-20;
writeln ('massiv ');
for i:=1 to 15 do
write (a[i], ' ');
for i:=1 to 15 do
if a[i]< 0 then a[i]:=sqr (a[i]) else a[i]:=sqrt (a[i]);
writeln ('novij massiv ');
for i:=1 to 15 do
write (a[i], ' ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота