В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
maksimgrig12
maksimgrig12
21.02.2022 21:18 •  Информатика

Составьте программу, которая формирует массив, содержащий 10 случайных целых чисел, принадлежавших промежутку [0; 7], и преобразует элементы массива по следующему правилу: к чётному числу прибавляет 3,а к нечётное умножает на 4

Показать ответ
Ответ:
vlad134631
vlad134631
26.05.2020 17:25

Program Program1;
var
i:integer;
a:array [1..10] of integer;
begin
randomize;
writeln;
writeln('Массив до преобразования:');
for i:=1 to 10 do
begin
a[i]:=random(8);
write(a[i],', ');
end;
for i:=1 to 10 do
if a[i] mod 2 = 0 then
a[i]:=a[i]+3
else
a[i]:=a[i]*4;
writeln;
writeln('Массив после преобразования:');
for i:=1 to 10 do
write(a[i],', ');
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота