В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
victoriya0205
victoriya0205
22.08.2022 06:13 •  Информатика

Составьте программу, которая формирует массив, содержащий 12 случайных вещественных чисел от -1 до 3, и подсчитывает произведение всех отрицательных чисел. вывод - в столбец с двумя десятичными знаками

Показать ответ
Ответ:
Yasmin76000
Yasmin76000
09.10.2020 22:03
PascalABC.NET 3.4.2, сборка 1978 (12.02.2019) program task31143948;const  N = 12;var  arr: array[1..N] of real;  Sum: real;begin  Sum := 1;  for var i := 1 to N do    begin      arr[i] := Random()*4 - 1;      Writeln(arr[i]:5:2);      if arr[i] < 0 then        Sum := Sum * arr[i]    end;  if Sum = 1 then    Write('ПРОИЗВЕДЕНИЕ = 0')  else    Writeln('ПРОИЗВЕДЕНИЕ = ', Sum:5:2);end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота