В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
BERE1337
BERE1337
21.02.2022 21:18 •  Информатика

Составьте программу, которая формирует массив, содержащий 16 случайных вещественных чисел, принадлежащих промежутку [-2; 3] и подсчитывает сумму отрицательных чисел. вывод в столбец с двумя десятичными знаками. только паскаль abc!

Показать ответ
Ответ:
Arthurkaa
Arthurkaa
26.05.2020 17:23

Program Program1;
var
i:integer;
sum:real;
a:array [1..16] of real;
begin
randomize;
for i:=1 to 16 do
begin
a[i]:=-2 + Random * 5;
writeln('a[',i,']=',a[i]:0:2);
end;
sum:=0;
for i:=1 to 16 do
if a[i]<0 then sum:=sum+a[i];
writeln('Сумма отрицательных чисел равна',sum:0:2);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота