В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Алена173
Алена173
21.10.2021 13:36 •  Информатика

Составьте программу которая копирует из строки "наступила холодная зима " слово "зима"

Показать ответ
Ответ:
Sashafgbjk
Sashafgbjk
26.05.2023 08:47
Var
i, k, n, j, z, x:integer;
b, c, d:array[1..10000] of integer;
a, e:array[1..10000] of string;
m:string;
begin
readln(n);
for i:=1 to n do
readln(a[i]);
readln(b[i]);
readln(c[i]);
for i:=1 to n do
for j:=1 to n do
if b[i]<b[j] then begin
m:=a[i]; a[i]:=a[j]; a[j]:=m;
z:=b[i]; b[i]:=b[j]; b[j]:=z;
x:=c[i]; c[i]:=c[j]; c[j]:=x;
end;
for i:=1 to n do
writeln(a[i],' ',b[i],' ',c[i]);  {это сортировка по тиражу}
for i:=1 to n do begin
e[i]:=copy(a[i], 1, 2); {тут расчет на то, что название начинается с заглавной буквы английского алфавита}
val(e[i], d[i]); end;
for i:=1 to n do
for j:=1 to n do
if d[i]<d[j] then begin
m:=a[i]; a[i]:=a[j]; a[j]:=m;
z:=b[i]; b[i]:=b[j]; b[j]:=z;
x:=c[i]; c[i]:=c[j]; c[j]:=x;
end;
for i:=1 to n do
writeln(a[i],' ',b[i],' ',c[i]); {сортировка по тиражу}
readln;
end.
0,0(0 оценок)
Ответ:
horizontal
horizontal
22.10.2020 09:07
Если вводить футболистов с клавиатуры и их не больше, например, 25 человек, то программа может быть такая:
Program futbol;
var fio: array [1..25] of string;
      gol: array [1..25] of integer;
       i,j: integer;
       f: string;
begin
   writeln ('Введите фамилии игроков, забивших голы');
   writeln ('Окончание ввода - пустая строка');
   j:=0;
repeat  
   readln(f)
   newfio:=true;
   for i:= 1 to j do begin
       if fio[i]=f then begin
             gol[i]=gol[i]+1;
              newfio:=not newfio;
             end;
       if newfio then begin
           j:=j+1;
           fio[j]:=f;
   end;
while not f='';

for i:= 1 to j do begin
  if gol[i]>2 then writeln fio[i];
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота