В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
aruzakova05
aruzakova05
26.12.2022 06:26 •  Информатика

Составьте программу, которая находит произведение четных чисел и сумму нечетных чисел в диапазоне от 1 до 10. в pascalabc

Показать ответ
Ответ:
влаласт
влаласт
07.06.2020 01:47

uses Crt; 
var s,i:integer; 
begin 
ClrScr; 
i:=0; 
s:=0; 

While i<10 do 
Begin 
i:=i+2; 
s:=s+i; 
end; 
writeln('Summa chetnih ot 1 do 10 = ', s); 

i:=1; 
s:=1; 
While i<9 do 
Begin 
i:=i+2; 
s:=s*i; 
end; 
writeln('Proizv nechetnih ot 1 do 10 = ', s); 
readln; 
end.

0,0(0 оценок)
Ответ:
kassaalevtina
kassaalevtina
07.06.2020 01:47

Program asd;

var chet,nechet,i:integer;

begin

for i:=1 to 10 do begin

     If (i div 2)=0 then chet:=chet*i;

     If (i div 2)=1 then nechet:=nechet+i

end;

Writeln(chet,nechet);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота